Database Table stuck in "Loading..."

The table is inside a strip that show on all pages, and the dataset is set to show on all pages.

So the first time you load the website, the database and table is able to load, but once you go to other pages on site, the table gets stuck in loading. I tried using refresh codes on the table and dataset, but didn’t work. The url is

Thank you very much for your time!

Hi Alan,

(I’m going great - thanks)

I’m having trouble figuring out where the problem is. There are so many pages - and they’re in Chinese.

When I try out the site, I don’t get any “loading” message and everything seems to display OK. But then again, I’m don’t really know what it’s supposed to look like.

Any chance to make it simpler to test?


Hi Yisrael,

I do apologise. When you hover onto the first button of the menu that says 品牌, it will prompt columnstrip77 to show, and within the strip, there is a table titled table1. The database seems to be stuck in loading once you enter into another page, and attempt to prompt columnstrip77 to show again. I do hope this would be clearer.

I have recorded a screenshot, thanks a lot for your help!

Hey Alan,

I think I got it. :exploding_head: You need to refresh the menu dataset to display the menu.

I added this to the beginning of the Site code and it works for me:

$w.onReady(function () {
   $w("#table1").onViewportEnter( (event, $w) => {

I really need a beer. :beers:


Dear Yisrael,

Thank you so much for your assistance. I am really grateful for the assistance you have given me. I have just added the code onto the beginning of the code, however, it doesn’t seem to work. I wonder if there is anything that I am doing wrong?

Thanks again!

Hey Alan,

I’m happy to help.

One thing I noticed is that you already have a similar line in your code on line #263:
But it shows an error:

This is because you’re missing the hashtag. It should be:

I tried this again and it works - most of the time. I suspect that somewhere you are not doing a hide() or a show() when you need. Sorry I can’t help you any more on this. It’s way too complicated with so many elements to keep track of. You should try to find a way to simplify the testing - maybe duplicate the site and make it simpler for testing. It really seems to me that there’s a problem with show/hide/refresh.


Hi Yisrael,
Thank you for your reply. The problem seems to be persistant. I’ve made a quick test site for you to test it. Just click test button on the right top corner and hover onto it and you will see. Thank you very much.


Did you ever find a fix for this? I’m having the same issue

Please add a new post with a link to refer back to this post rather than bump an old thread from 2018.

Try checking the dataset used for the table connection and make sure that the permissions are set for anyone.

Old post being closed.