Autoplay video without black bars

I’ve gone through all previous forum posts to see if I can find the answer to this, to no avail, and I have work due to a client this weekend and need to get to the bottom of this ASAP, so here I am posting:

Is it impossible to use a video background in EditorX? Whether I use the Single Video Player (which I need to, in order to be able to remove the play button), or the Video Box, stretching the video doesn’t work. At first, in the editor, it looks like it will, but as soon as I move to preview, black bars stretch horizontally across the sides of the video. Nothing I’ve tried to fix this has worked. I found an earlier forum response that suggested using GIFs to get past this, but GIFs are extremely large files, not suited for website usage. When I tried using a GIF, the stretch technically did work, but the GIF added pixelation and looked nowhere near as good as the video–while being 8x the size, WAY too large for a site to load.

The last post I could find directly on this subject was from spring of 2020 (that’s the one with the GIF suggestion). Has there been any progress since? How is it possible that something so simple in the normal Wix editor could feel so impossible in Editor X? How do I get around this? I’ve just transitioned to Editor X this week, knowing it would set me back gently in terms of getting work to my client, but this bug is SIGNIFICANT. Are there ANY solves?? Thanks in advance–I could really, really, use some help here.

1 Like

WHAT THEY SAID! @jossakelvin

@jossakelvin I am experiencing the same. Any solution?

in case you want to use video as background for sections , you can do this with Patterns option
in case you have issue with black gaps in general, please try videobox instead of single video player

please let us know, if this will work for you, or share more details, if this is not the feature you are referring to

1 Like