Experiencing lot of lag with the new dataset Live Preview

Since Wix has released the new dataset Live Preview feature where items from the database are auto loaded whenever you connect a repeater to a dataset on the page (while still working with the editor) its becoming difficult to work with the page having the repeater and dataset. So much lag and my CPU and Memory usage goes up a lot whenever I open the page or start moving elements around.

Can we get an option to disable it? Even without the lag I don’t want items populating from the database when I’m still using the Editor.

Maybe it’s time to upgrade your computer, it works on my side, even on some large database :thinking:

1 Like

But not all users got fast pc, disable will be a great way to solve these issue. #featurerequest

I play Cyberpunk 2077 on my computer but need to upgrade for a website builder? :joy::joy::joy: Oh man :joy:

OMG😂

@shantanukumar847 are you sure it is related to that? I’m experiencing issues as well - see: https://www.wix.com/velo/forum/coding-with-velo/today-s-wix-editorx-performance-issues It’s also about a page that has a dataset connected to a repeater.