Pattern Validation does not appear

I am attempting to follow this reference . However, I don’t see an option to specify a pattern validation in the settings. What am I doing wrong?

Hi there,
Is your input element connected to a dataset? Connect it first, and then the option will appear: