Unable to edit 'success message' on custom form

Hey guys, the title pretty much explains it all.

The editor worked perfectly fine yesterday, but all of a sudden I’m unable to make any changes whatsoever to the success message on my form.

If I select the button connected to ‘submit’, and then click on ‘+ Add success message’ or failure message, nothing happens.

So, I tried to circumvent the issue by manually adding a text element and connecting it to ‘Submit Succeeded’. It allowed me to connect the text, but automatically changed the text to ‘Your content has been submitted’, and doesn’t allow me to make any changes.

If I try to edit the text, it just says the text is managed in the form’s dataset.

However, there is no field for this in the dataset, and I can’t find information anywhere about some sort of hidden ‘submit successful/failed’ setting in datasets. Also, I’ve tried this on Edge, Chrome, Opera, and Firefox - it doesn’t work on any browser. I’ve also tried clearing my cache and cookies, etc. didn’t do anything.

There have been all sorts of weird little issues with EditorX lately, so I hope this is something that gets fixed ASAP, or that everything gets sent to Wix Studio by next week, cuz I’m getting really tired of the issues and this one is a blocker for me.

Don’t connect the text you created to the form, customise way you want, hide it, then create an export function like in this picture and add a show function to the text.

1 Like

Gonna try this now, will reply in a few with an update.

Although, is this a normal issue? Not sure if it’s just me having these issues now, but I wasn’t having these issues yesterday.



There is no such problem in my contact form. I didn’t quite understand why this happened. Probably because text is connected to contacts-MAIN collection. You can unlink text from dataset and try again, otherwise you can do the first way I showed.

Good Luck!

Unfortunately, the code doesn’t work for me. I’m not using WixForms, and I can’t seem to find the right code for it to work for a custom form.

I’ve tried pretty much everything else. I’ve tried deleting the dataset and trying again, I’ve tried using another collection completely, and I even just tried restarting my computer.

Nothing works.

At this point, I really have no idea what I’m supposed to do, because none of the intended solutions work. Adding a ‘success message’ through the button doesn’t work for some reason and connecting a text element to the custom form via ‘submit succeeded’ prevents me from customizing the text. This is incredibly stupid.

So, for anyone wondering, it was some sort of glitch with EditorX.

Clicking on '‘+ Add success message’ or failure message actually did add a text element, but it teleported it into the top section of the website and stuck it at the top left, thus hiding it under other elements.

Took me and support almost an hour and hundreds of created text boxes to figure it out (thanks josh!).