Unhide Hidden Element

Here is a brain teaser… hope someone can help here:
I wanted to display certain element in Mobile only and hide it in Desktop.
I’ve done what it says [here:](here:

Works)
[Velo Tutorial: Displaying Elements in Mobile Only | Help Center | Wix.com](here:
Velo Tutorial: Displaying Elements in Mobile Only | Help Center | Wix.com

Works)
Works Perfectly!

But now, I want to delete this element.
The problem is I cannot.

  • I can’t mark it in “Layers”. It won’t choose it upon click. So the “Property & Events” section is not visible to “Unhide”.
    See Picture 1: When I mark “HTML1” in “Layers” the “Property & Events” section is visible.

See Picture 2: When I try to mark “mapmob” in “Layers” the “Property & Events” section is not there because “mapmob” can’t be marked.

  • Since I can’t mark it in “Layers” I can’t even simply click delete.
  • “Turn on spotlight” doesn’t show it either.

So…
Any suggestions?

Thanks!

I suggest you contact Wix Customer Care as it appears that this might be an issue with the editor.

Thanks @yisrael-wix
But it’s now fixed.
I don’t know how and why, but I was in Mobile view in the editor and then could select the “mapmob”. Once selected I unchecked the “Hidden” checkbox.

I don’t know why it was possible all of a sudden, because I did go between Desktop and Mobile views many times, refreshed over and over, cleared cached, logged out and back in, you name it.

But eventually, it just got solved on it’s own… :kissing_smiling_eyes:

Magic!