Button to change state on multi-state box stopped working

My code was working up until the other day and now it’s stopped working.

I have buttons to change forms on multi-state boxes, and now all the buttons on my website for the multi-state boxes don’t work.

The code I’m using (and worked before) is:
$w . onReady ( function () {
$w ( ‘#btnNoticeboard’ ). onClick (() => {
$w ( ‘#stateBox’ ). changeState ( “Noticeboard” );

$w ( '#btnMarketplace' ). onClick (() => { 
    $w ( '#stateBox' ). changeState ( "Marketplace" ) 


Any help is greatly appreciated ! :blush:

Some questions:

  1. You changed something on your page?
    a) you cahnged some codelines in your code?
    b) you changed something inside your multistate-box?
    c) you changed the ID of your MSB ?
    d) you changed the ID of your button?
    e) you changed the IDs of your STATES of the MSB ?
    f) you don’t get any errors inside the CONSOLE ? If you get errors, which ones?
    g) if you didn’t change anything and your code do not work anymore, maybe it is an error on wix-side?

this bug affects all my sites.
This is reflected in the use of multi-boxes
When there is internal animation on components inside the state, on the first interaction everything works but on the second interaction When switching between states the animations do not work which causes the components not to be displayed ( The components inside are touchable but hidden )

:persevere: The bug started Yesterday and it affects all my sites that use multibox (very critical, it’s about menus and contact forms)

:thinking: I contacted Wix support on the issue and it is being processed

Hope they take care of it quickly

It looks like it’s working again - which is weird and annoying, because I spent a couple of hours trying to debug and just left the original code in the end. Looks like it was a problem on Wix’s end?

This sounds a lot like my issue. If you find a workaround, please let me know. I had a call with Wix yesterday who have escalated it to Velo, and am waiting for an email from them now.

Having the same issue. I am told some people can get some of mine to work, I cant get the multi-state boxes to work on any browser. Nothing has changed since last week when they all worked.