Hey, can anyone help me to find why Wix wont let me add the blog and the store page to menu? thanks:)

so I’ve been trying to add a Blog and a Store to my Graphic Design website. I tried to create a way so that visitors can acess those pages through menu or a button, but the editor wont let me add neither Blog or Store. Can anyone help me?

Captura de tela 2023-11-02 232114

1 Like

@g_pixels Did you ever find a fix for this I also have this same issue.

Hey @g_pixels & @MattH!

Good question. I can understand how it might be a little confusing, and this is great feedback that we’ll share with the team.

In the meantime, when adding an item to a menu, choose “Link” rather than “Site Pages”.

You should then be able to add the Blog Page from this popup :slight_smile:

Screenshot 2023-11-13 at 17.01.42

It doesn’t work with your work around. The Done button isn’t highlighted when you try and add it as a link instead of a page. Thoughts? I need people to access my blog. Thanks.

Your solution is not working, you cannot select Categories which makes the Done button grayed out.

The Wix founder made all his money, this is now a shell company with three dudes in a basement running it. There will be no fixes or new features of any value going forward.

Hello everyone, I was finally able to get this working. You have to create at least one Category. Go to your Dashboard / Blog / Categories


Once you have at least one category, you can then add the Link by selecting either your one category or you now get the option of All Categories. The important thing is that the Done button is not greyed out. :slight_smile:

Manage menu > Add item > Link > Choose which page > Scroll to bottom > select Blog

Hello! I had the same problem even reading everyone’s reply. I contacted Wix Studio customer service twice and finally got it fixed. Here I’d like to share the details for the solution to help people who encountered the same problem like I did.

  1. Because blog is an extension so the link needs to be created as “link” in the navigation.
  2. You need to create a category and a blog post first and then you need to “Publish Your Site” first, then you can go back to your navigation bar and set up the menu to add a link to the blog.
    The solution offered by others simply didn’t say “you need to publish your site first” and that’s where I got stuck. Hope it helps.
2 Likes

Yay! You’re the best. Thank you!

I’ve published my site and the site no category option shows up, even though I made one. I then published four times, but nothing. Only after I backed out of the site and reloaded it and published did the option finally show up.