Html lang tag

Hello,
My site is Portuguese, i have everything set-up to portuguese, but the html lang tag shows up as ENG.
How can i change this?

Hey,
Can you please send us a screenshot of what you were referring?

Thanks,
Tal.

1 Like

Hi,
Currently, there’s no option to change it. However, this is on our backlog.

Best,
Tal.

Hi, this is really required as it affects very badly any SEO Optimisation. Running a Hotel website so for us it is highly important to have this solved ASAP

Hi,
Currently, as mentioned above, there’s no option to change it. I’ve forwarded your request to the relevant department. I’ll get back to you if there’s a change with the status of your request.

Have a good day,
Tal.

Hi Tal,

thank you very much for your reply.
please tell your colleagues that having a correct language tag is essential for google.

if a website has an EN tag but actually. the targetgroup is DE then this is an issue which will prevent users to find the page since google will give it a lower priority in its listing.

For Wix this also has a businesscase since without such an option customers might not continue their premium and chose a solution which does support such a function.

Hi guys,
After re-checking it with the relevant department, I’m glad to inform that there is an option to change the tag through the dashboard:


Click here to learn more about it.

For further questions about it, please contact Wix Support team as they know best about this feature.

Have a good day,
Tal.

Hi Tal,

thats wonderful news.
However, i tried and the language tag is still EN.

Hi,
This forum is specialised in Wix Code product. For further questions about this feature, please contact Wix Support team as they know best about it.

Thanks,
Tal.

Tal,

i appreciate your answer. However, you post here that it is solved and we can now change the language tag.
But it is not solved since the changes have no effect.
There is not much which the enduser can do wrong here.

Set language in the box , as per your screenshot and hit save.
Checking website, clearing cache, all the same.

No need for support, since the feature you posted is simply not working. Please check for yourself.

1 Like

If there’s an issue with this feature, you should contact support directly as they have the ability to check if there’s a bug with this feature. As stated above, this feature is not related to Wix Code therefore I cannot check this issue on my end.

Hello, i have just tried this sollution and it work for me . html lang tag is in PT now


Thanks

1 Like

Hey, as suggested i wrote to support on May 15th.
Today i finally got an answer… that i should ask here.

Very Funny…So what now?

Hallo Michael,
vielen Dank für deine Nachricht, wir helfen dir gerne.
Du hast das Hilfe-Center von Wix kontaktiert. Für Fragen bezüglich Wix Code wende dich bitte direkt an das Support-Forum von Wix Code.
Wenn du einen Fehler findest oder Feedback zu dem Produkt hast, sende uns dieses direkt über das Feedback-Formular .
Beste Grüße

Hi,
Can you please send me the ticket number? I’ll check it with the support department.

Thanks,
Tal.

735238429
Thanks Tal

735238429
Thanks Tal

Hey Michael,

To fix it you need to change your site language under “Settings” → “General Info” from your site’s dashboard. If the language is already set to Portuguese you need to change back to English and then again to Portuguese. Now the language in the HTML lang tag should be Portuguese.

I hope this helps!

Best wishes,
Christoph

1 Like

Worked!