Performance Issues with Multi-state Boxes

Hi all,

I’ve familiarised myself with multi-state boxes on several sites, and love the performance of the expanding, and collapsable elements. However, I’ve run into an issue on one of my sites. From the screenshots, you can see all elements untouched, but as I go through the list, expanding them and then collapsing them, the main blue strip they’re within, extends each time, but never returns to its original size after I have collapsed an element.

What would be the reasoning for this / how do I rectify this?

Please post the URL of your site and Indicate what page.

Please see direct link to the page

https://compliancehub.wixsite.com/my-site/agency

@harleyweber I’m playing with that page and don’t see a problem. Each item expands, and then on collapse everything goes back to normal. I tried this on my Mac with Chrome, Safari, and Firefox. All good.

Make sure that you are using a supported browser .

1 Like

@yisrael-wix How odd! Thank you for checking. When you did test it, did the blue strip also go back to its original size upon collapse? Or did its size increase with the text expansion, and therefore not return?

@harleyweber Everything goes back to normal, including the blue Strip. Works just fine.

1 Like

@yisrael-wix Thanks again for looking

@harleyweber BTW - I also tried without the recent performance release and it behaved the same for me, just fine.

If you can identify some particular scenario or situation where this happens, let us know. However, in order to assist with this, I need to be able to reproduce the problem.

If you continue to encounter this issue, you might want to check with Wix Customer Care . They might have some idea.

1 Like