Please help me figure out how to fix my menu

Hey everybody

I originally had trouble with my hamburger menu that opened a vertical menu months ago, but fixed the problem. Since then, some update has unfixed it, and I can’t get it to work anymore. I am working with a completely different hamburger menu at this point (the old one was being weird) and have completely thrown out the dropdown, but no scroll. It has given itself (the container) a height and it won’t let me take it off. Losing my mind. Anyone else experienced this?

@elfloftpigeons Can you share a bit more about what you are experiencing? is the menu container stuck? Can you share a screenshot or a link to your site/editor?


Hey there, sorry for the gap - I’ve fixed the issue, though I’m trying to figure out why it worked today and not 5 days ago; maybe I forgot how it needs to be done? Anyway, for whatever reason the vertical scrolling menu on my site doesn’t want to scroll all the way down if left alone. The container of the menu has to be set with at least 30 vh bottom padding to work correctly on mobile - I tend to set it at 32 in case somebody needs extra wiggle room. I don’t know why, but during my last edit that had broken and I needed to fix it, but I either wasn’t doing it right or it wasn’t reading me right. Oh well. It’s fixed now!

I also have a mobile menu that was working as expected and scrolling (when the submenus were toggled down) until recently it suddenly stopped having the ability to scroll. And I had not changed anything. Since then I have tried several things and have so far been unable to get it to scroll again. My theory is that it stopped working when the “Pinned Position” was released.

I agree, I think that kind of “jolted” everything. I had to throw out the first container the menu was in and choose a different hamburger menu to work with and then… idk, wait 3 days? But I would throw out the first menu and start again if you can. I have never been able to get a correct scroll without messing around with it anyway, but I’ve at least narrowed it down to just fussing with the vertical padding.

You were right, I deleted the existing menu and added a new one and the scrolling immediately was working again as expected.

Weird, and not ideal, but at least there seems to be a concrete fix for