The site works in Preview, not in Published

I need help figuring this one out, it sounds simple but I cannot get it to work.

I have a form where users can enter a ship-to address. These addresses are stored in a collection so they can be updated, deleted, etc. Everything works in preview mode and I was using a test site to get things tested with a non-admin user account and it works there as well, but for some reason, it doesn’t on the published site (tested with both Admin and non-Admin account)
I’ve tried everything, from coding the dataset save, to changing the collection permissions. There really isn’t any code to this, but I can’t figure out why it won’t save.

The permissions setting I’ve tried are:
“Anyone” - for all settings
“Member Generated Content”
and many different combos.

This continues to work flawlessly on preview, but not published.

I tried deleting the dataset and re-adding it… no improvement
I’ve tried renaming the dataset… no improvement

Additionally, I’ve tried multiple browsers and lots of refreshing the page.

Any help is greatly appreciated!

import wixWindow from 'wix-window';

$w.onReady(function () {

export function dropdown1_change(event) {
  let country = $w("#dropdown1").value;
  setDropdown(country); //this function changes the dropdown menus based on country selected. This code is a ton of line and not a cause of the issue. 

So I created a brand new test page with all new elements, dataset, everything… same result. Seems like it should be a permission issue, but I can’t figure out where the permission issue is.

Did you sync the sandbox collection with the Live collection?

When researching this issue, I came across that tutorial, but I don’t have that button. When I make a change in preview mode, there is a banner saying change will be live when published. (see image). But there is no button for syncing sandbox to live like the tutorial shows.

UPDATE: No clue why, but I login to the site this morning and everything works. Doesn’t make any sense, last night nothing was working and I’m the only editor of the site, this morning everything works as expected… very strange.