Website Header Issue


I’ve built a website for a client. The thing is the header has white background. When I go into Editor Mode & Preview Mode while in Editor, it shows correctly with a While Background for the Header. But if I come out of it and go directly to the website, the Header is merging with the Banner in the Homepage.

I added a Search Bar a few days back, but at that time I didn’t see this issue. I thought it might be the Search Bar and removed it and published the website, but the same issue still existed.

PFA screenshot for reference:

The URL is

Please let me know if there’s any way to fix this.

Thanks & regards,

Maybe you can contact the wix support for that ?

Yes. Just wanted to check in case any one else was facing the same issue and fixed it.

Hi, thank you for sharing this with us. If you haven’t reached out to support, I recommend you do, so they can investigate what might be happening here.

Keep us posted with any news you find out! It may help someone else who may experience this issue. :slight_smile:

I’m having the same issue. They have said its because I’ve pinned items in the header and told me to unpin them.

Unfortunately that doesn’t help as I need to pin the items to make sure they show correctly on all screen sizes…

1 Like

I also think its got something to do with the new search bar as every site I add it to causes this issue, yet when I delete it its works fine again…

1 Like

Yes! Same here. And another issue I’m facing with WIX Support is every time it’s a different person answering the same ticket. I end up having to explain everything again, and they give the same response that “You haven’t Freezed the header” or “You have pinned the element and have to unpin”. Unfortunately, nothing works.

I got fed up and reached a point where I just changed the font colours and added a background to the logo so it’s visible on Desktop & Mobile. I couldn’t come up with any other workaround apart from this. :expressionless::man_facepalming:t2:

So it worked for you once you deleted it? I tried deleting it and publishing the website, but it didn’t resolve the issue for me. :frowning:

@tools16768 The fix has stopped working for me now, so unsure on whats changed sorry!

Do you still need a hand with this? Happy to help.