Why am I getting a bind error from my back-end code?

I recently started getting the following errors in my console log:

Error loading web module backend/http-functions.js: Cannot read property ‘bind’ of undefined

The error points to line 6 column 1 which doesn’t make sense:

import { authentication } from ‘wix-members-backend’ ;

This happens on any of my get functions in my back-end. It is as if somehow the export async function get_utils ( request ) main function for processing my various GET requests is no longer bound. But I don’t know what I might have done to cause this.

What do I look for?

My back-end is completely not functional at this point.

There’s a known bug with the new ‘wix-members-backend’ on the routers file.
I suggest that you use the old wix-users until the bug is fixed

(Only if you need it urgently for a live site, otherwise - wait for the fix).

Luckily I found this post as I have the exact same issue. Sure it was working the other day but hey ho. You mention this is a known bug, is there a list anywhere of the known issues?

@J.D. -

Do you mean wix-members? wix-users doesn’t have an authenticate function. I made the change to ‘wix-members’ instead of ‘wix-members-backend’ and I am still getting the same error.

There’s nothing on the status page about this. Was definitely working yesterday so something broke in the last 20 hours. Looking at the forum looks like a few modules have broken!

Yup, I think so to. Seem to be getting this on every ‘backend’ module I’ve tried.

1 Like

Just change anything on your site and stay a little bit patient.
If after 3-4-days the issue still exists → Wix-Customer-Care!

@russian-dima 3-4 days??? maybe 3 - 4 hours, this ain’t the post office!

1 Like

I don’t think my problem has anything to do with me using wix-members-backend, unless they changed something. I am only using it to implement the new password reset function they just released, but now I am not even getting that far.

My mobile users use the back-end functions when they log in. They can’t even get that far now.

I’m having this issue as well.

This afternoon my code which used wix-users-backend and which worked fine all year stopped working and started throwing up this error:

“[“Cannot read property ‘listMemberBadges’ of undefined”]”

When I tried updating to the new wix-members-backend it started giving me this error:
“[“Error loading web module backend/badges.jsw: Cannot read property ‘bind’ of undefined”]”

Is there a bug with both these modules?

First of all, it’s a brand new bug, and since it’s a severe issue, I’d guess it will be fixed really fast. So maybe you’d like to wait a little bit.
Second, I meant to use wix-users-backend with the alternative methods that do things like the authentication.

Seems to be a problem on Wix-side. Tag → @marlowe-shaeffer ← always very fast resolving issues!

1 Like

I’m getting:

Uncaught (in promise) TypeError: Cannot read property 'bind' of undefined
    at Object.<anonymous> (@wix/wix-members-backend/index.js:463:54)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Module._compile (node_modules/pirates/lib/index.js:99:24)
    at Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at newLoader (node_modules/pirates/lib/index.js:104:7)
    at Object.requireThatAddsUserCodeDirs [as .js] (node_modules/scoped-require/index.js:29:14)
    at Module.load (internal/modules/cjs/loader.js:928:32)
    at Function.Module._load (internal/modules/cjs/loader.js:769:14)
    at Module.require (internal/modules/cjs/loader.js:952:19)
    at require (internal/modules/cjs/helpers.js:88:18)
    at Object.<anonymous> (backend/mailer.jsw:2:1)
    at Module._compile (internal/modules/cjs/loader.js:1063:30)
    at Module._compile (node_modules/pirates/lib/index.js:99:24)
    at Module._extensions..js (internal/modules/cjs/loader.js:1092:10)
    at newLoader (node_modules/pirates/lib/index.js:104:7)

for line

import { currentMember } from 'wix-members-backend';

This was working last night and annoyingly I just completed my off site (wix) section before coming on to finalise…

wix backend secrets works


Like I said in my post, I’m not even getting to the point of calling that authenticate function when the back-end blows up. The only way I’m using that authenticate is when a user wants to reset their password, utilizing the new password reset capability that was published a month or so ago (and was working fine then).

Today, all my mobile users are causing this error on the very first function that my mobile app utilizes, which is to validate a device ID I’ve generated for each device (and stored in their local app preferences) against values in a Velo collection.

Here the next one?


And another one???

@russian-dima Seems to be within the last 45 minutes that this started, looking at those posts.

The first post was already yesterday, or even earlier…
I think this one could be the first one …

1 Like


I was the first post. It was 49 minutes ago now.


1 Like

@russian-dima Bugs must’ve entered via npm and infected wix backend!

Is this wix’s way of saying we’re working too hard and need a Tea break… Well, a valid excuse as any, I suppose. :slight_smile: