Adding image if layouter is widen and set as slider

Hi, guys I watched this video and I found I can’t follow the same way like she did in the lecture,

the problem is I cannot scroll for adding image if layouter was set as slider.
does someone know about this?

1 Like

I’ve had the same problem here since EditorX was beta; haven’t managed so far, and I think there’s sadly no workaround here (I might be wrong) but to keep asking 4 help to the EditorX Team about this. Sorry \:

Thank you Ricardo, yes I hope this problem get solved soon

Hey @oseongwonosw @ricardoherrera994 - could you share a bit more info? Which browser are you using and are you on PC/Mac?

@sebi-vidret fyi


Also, it would be helpful to know if you are using a trackpad/mouse/mouse wheel to scroll to the right

@eduardog @sebi-vidret
Hi, thank you X Team
I used window10, and Chrome browser and normal mouse and keyboard
here is video of my problem

@oseongwonosw When you go to preview or publish, do you still have issues? It looks like you were on the editor from the video shared.


yes but my issue is just that, in edit mode, I cannot put image cuz I can’t scroll to 3th or 4th layouts.

1 Like

I happen 2 use Windows –I haven’t tried Linux or Macintosh– and it happens in different machines in every chromium or not-chromium-based browsers (from edge legacy to chrome/brave/vivaldi/etc).

The issue follows as this: in order to add more horizontal content in an horizontal-scroll layouter once its viewport is covered with the first contents, you have to scroll in order to access the other layouter items, but it’s impossible to do so from the editing mode; only the preview mode and the published site allow to scroll (by dragging the overflow bar or wheelscrolling while holding shift) but that serves no purpose since it needs to be achievable from the Editor per se in order to be… well, editable

Additionally, the horizontal scroll by mousewheel works but –as said in the previous paragraph– only while holding SHIFT key, which is not intuitive or user-friendly, and so far there’s no way to ‘hack’ it into being automatic through Velo nor custom elements ://

1 Like

Hey @oseongwonosw , I’m Dolev from Editor X.
I’m sorry to hear about the bad experience that you had with the layouter.
As for today, we have a bug with the slider feature so you will not be able to scroll through the different items unless you are using track pad or a laptop with a track pad.
We are working on fixing this bug ASAP.

This still doesn’t work, is there any update on resolving this?

My workaround is to add a new item to the Slider, which auto-scrolls the slider to focus on the new item, and you can add a new element from there.

But there’s no way to then access & modify older items once they go off-screen…

Will forward this to the team but the other thread mentioned, but you can use a touchpad to move between items. You can also use one layout option and then switch it.

Hey Dolev,

You are working on fixing this bug ASAP, it has been over a year and this still doesn’t work, any updates on this? should we wait another year or two?

1 Like

This is not a solution. you assume all users have touch pads because you all work with macs? what about people who use PC desktops? al lot of us out there.

Even if I go to preview, scroll and than go back to edit, the slider scrolls back automatically to the previous items, so I have no way of editing new added items in the slider.

Relying on the touchpad is not a solution and this should be fixed.
no workarounds, no magic, just fix it please

This has been broken since Layouters first appeared and it’s still not working.

I’m trying to add a Lottie file to each Item in a Layouter Slider and am experiencing the same problems trying to get content into an Item other than the first one. It just does not work.

~ Re-ordering Items doesn’t work, Items can’t be dragged / dropped successfully.
~ Layers & Inspection panels do not correlate on Items ordering.
~ Impossible to Copy / Cut / Paste a Lottie container to an Item, it either jumps to the parent container or doesn’t Paste at all.

Am I missing something, or is this Layouter Slider functionality just completely broken & no one is interested in fixing it?

Extremely frustrating…

In all seriousness, if it’s not possible to add to content to Layouter Slider Items at this time, why not just disable it & take it out of use?

Many hours of valuable design time have been spent trying to get this basic functionality to work. It plainly needs a caveat attached, explaining the current limitations, or withdrawing altogether as a layout option until it’s fixed.

We are working on fixing this bug ASAP ’ - Dolev Brosh > It’s now 18 months on, so this plainly isn’t the case. Please stop brushing us off in this fashion.

Could someone from EdX update us on the progress in resolving this issue please?

Please see my comment to Edu Giansante below.

I’m on PC laptop actually but apologies if my video wasn’t clear enough or made it sound that you need to have a trackpad or go purchase one.

I understand the complaint and the frustration but you can change the layout to be able to see all of the items and work that way; you could also arrange the newest items to the front if you prefer working within the slider layout so that you can see how it would look beforehand.