Events Widget: Disable Zoom Effect?

I’m experiencing an issue with the Events Widget in Wix Studio, specifically using the side-by-side layout. Whenever I hover over the images in this widget, there’s an automatic zoom effect that I’d like to disable.

I’ve attempted to target and override this effect using CSS with no success. Here’s what I’ve tried:

  • Adding CSS rules to directly target the image and its container, setting transform: none !important; and transition: none !important; on hover states.
  • Using Chrome Developer Tools to inspect the elements and modify styles during hover, but the zoom effect seems to be controlled in a way that isn’t affected by straightforward CSS overrides.

Does anyone know how to specifically disable this hover zoom effect? Perhaps there is a setting in Wix Studio that I’m missing, or a more specific CSS trick that could help. Any guidance or insights would be greatly appreciated!

I guess you added CSS to Wix’s event widget, if the widget is the TPA one, CSS overrides will not work because TPA widgets are not supported by CSS yet!

I’m using the Wix Events & Tickets app by Wix

That means you’re using the TPA event widget made by Wix. Like I said, TPA widgets are not supported by CSS yet, that’s why you can’t override it you’re using event list, member list, event calendar.etc . Try adding the animation to the container and add your widget into that container.