Hide overlapping elements when editing underlying page

I have several container boxes being used as a menu system and are activated on mouse roll over (buttons). They need to be set to show on all pages and pinned. (Wix menu is too plain for my needs)

My problem is this: when I edit individual pages those boxes are sitting in the middle of the screen and even if I right click and select the underlying page via ‘overlapping items’, those boxes are still there.

Is there anyway to hide those boxes under the page I want to edit? I tried deselecting ‘show on all pages’ but then that deletes the onmousein/out function calls to those boxes…

It would be great if wix would simply implement advanced menu systems where drop down sizes can be adjusted and images or anything else can be added to them…but: until then there seems to be no other option.

Very frustrated – please help!

Hi Stephan,
This forum specialises in wix code product , please contact support@wix.com
for further assistance.

Have a nice day and best of luck!