How do you change text color on a dropdown menu on a Wix form?

Hi all,
I have added a Wix contact form to my site and I have not been able to find how I can change the text color in the drop down menu specifically in the telephone number field - Country Code. The field placement text is black which is fine, but as soon as you click the dropdown, all the text is in yellow which can’t be seen against the white background. I just want to change the dropdown text to black, but when I click the design icon for that field, then select text, I don’t find an option to change the color of the text in the dropdown. Thanks in advance!

im facing the same issue, have u figured urs out?

Click the dropdown → Design → Customize design → Click “Dropdown List” → Click on T for Text → choose color

i do not have a click drop down list option in step 4, i only hav an input field option to edit

IMG_0045

I’m on phone and not by computer, so this isn’t the correct design box on the picture, but it’s similar.

The option you’re looking for should be by the red circle.

Otherwise you might be using a different editor than I am

Cheers and happy new years :seedling:

I am having the same issues as the OP and have just logged a support ticket.

This works for regular menu design on the site, but this option is not available when customising Wix Forms which doesn’t seem to use those defaults. The only text on the input fields you can edit is the form field, placeholder and input text - no options for the drop down menus.

I’m having the same issue. Some fields have backgrounds (textbox, dropdown), some don’t (checkboxes radio buttons). This means that if you choose a light background with dark text for your textboxes and drop downs and you add some checkboxes, you’ll find that the check boxes are dark text on dark background. There’s no way to set text color separately for each.

This seems like a serious oversight. A work around that I’m using is to use a dark color background for textboxes, so that I can make the text lighter, thus fields without a background will work as well. But, this is not ideal. It’s a compromise.