Unable to delete rows

I’m unable to delete rows in my Sandbox.

I’ve checked the permissions. I’m the admin, so I’m supposed to be able to do this.

I have attempted this on 2 different browsers. Apple OS Chrome Version 64.0.3282.186 (Official Build) (64-bit). Apple OS Version 11.0.3 (13604.5.6). Both are up-to-date.

I hold down the Control key while pressing the row number and an option to delete does not appear. I get a system dropdown menu instead (Save As, Reload Frame, etc.).

I am able to click and select multiple rows while holding the Control key. However, again the option to delete rows does not appear.

Screen shot of the rows is attached.

Is anyone else experiencing this issue?

yes I definitely am, i tried on a Windows computer and my mac so im not sure what the heck to do on this one.

Hi Kev.

Can you please share your site’s url to take a closer look? I cannot recreate this issue.


omg i figured it out!!! its a christmas miracle ! on a MAC you have to use TWO fingers to click and it will pop up!! instead of trying to figure out how to right click lol man i feel like i find the cure for some deadly virus lol man ! whoo hoo :slight_smile:


OMG you’re right, Suzanne! That totally fixed it. It’s two fingers on the trackpad and the menu pops-up. Good to know!


PS - Wix crew, definitely recommend putting this instruction someplace on the database screen, or as a pop-up as users attempt different button combinations (such as control-click).


Thank u Kev! seriously tho i was going nuts everyone was just like just right click! im like really?? i must be going nuts bc it isn’t happening … LOL

1 Like

You guys, I have been looking for this answer for about a month. Thank you!

1 Like


1 Like