White space between header and first section

Hi - hoping someone can help. I have a white space between my header and first section. It is not as noticeable on normal view, but when I switch to mobile view, it’s quite a large section.

I have a simple header with a hamburger menu on the mobile view and a gridded section. As you can see from the screenshot, the green area is the selected header, the image is the top of the section. The white space in-between I am trying to remove.

Any help is appreciated

Hi, have you checked if there is a margin set that you didn’t know about? It could be pushing your section down, creating the white space.

I have looked at both the margins and for any padding, though i can’t seem to find any margins for the header.

If i set a negative padding on the image, it takes up the white space, but the section itself does not move up. Not all my pages have an image at the top so it can’t apply this as a ‘workaround’

Found the issue. Clicked on my header, then on the three dots to bring up the menu. When i clicked on Detach from Masters, the space disappeared. So did my header, has now become a section. Not sure exactly what happened, but that has resolved my issue

@slade273 happy you found the issue!

I’ve got the same problem on tablet view…desktop looks ok

There’s no ‘rogue’ section between the header & 1st section, nor any bad element, and no margin or padding that I can see between the two that could be causing this.

There’s no element in ‘Layers’ that can be selected to identify which element might be causing the problem.

I don’t want to ‘Detach from Masters’ as Steve has done to try to fix the problem - I’m unsure of the consequences site-wide & the site is too far advanced for me to risk messing it up at this stage.

Is this a bug?

Or can anyone suggest a way out of this?

I’ve been able to fix this…

By toggling ‘Overlap next section’ on/off, Header height looks to have been reset to what it should be and the gap removed.

Hope this helps someone else who gets this issue in the future…

I tried this method and now my section gets cut off by the header if its stretched. The grid seems to be underneath the header so the content inside the grid goes under the header when stretched.

1 Like

Did you toggle the overlap off? If so, might recommend contacting support so they can take a look.

Wanted to bump this thread but if you see this issue, please contact support to report it.

There are two workarounds that were mentioned by Steve Slave and Keithc which are to remove the master from the relevant pages and re-add them or to choose toggle overlap and then turn off the toggle.

This seems to happen if you change the sizing of a pinned header so if that is not the case for you, please reach out and the team will investigate.

Curious if there has been any sort of fix for this besides the two work-arounds posted or maybe an explanation as to what the root cause may be. I tried detaching the header from masters and that worked but when I reset it to master it returned to the previous behavior and now I can no longer detach from masters. The pinned header toggle overlap works to remove the space but ideally I’d like to have the default positioning for the header. Any help or ideas?

best option for you would be to create an appeal to Editor X Customer Care, so they can take a look from their side, or forward this situation to the relevant team for further investigation and resolution

This worked for me too!