Wix site in android webview

Starting a separate post to make this a clean discussion / possible solution. Apparently lot of developers still have the issue of Wix site not showing in full screen mode (with whitespace gaps on either sides of the site) using android webview.

We had exact problems with our sites not showing up full screen in webview. After doing lot of research (including on this forum & other places) and experimentation, the following is what worked for us. No need to do anything on wix side.

Include the following in .java file;

WebSettings settings = webView.getSettings();
settings.setUseWideViewPort(true);

Good luck and hope this helps

5 Likes

THANK YOU SOOOOO MUCH. I’ve spent days trying to fix all the issues I’ve had with webView and my wixsite and this was one of my last issues. Thank you.

On a side note, I am using wix forums and when I go to post a photo or use camera nothing happens in my webview. Works fine in a normal mobile browser. I have given my app all necessary permissions and set up requests for when app opens but still nothing.

Would you know what this issue may be?

1 Like

I was going crazy with this topic thank you very much!

You came like angel for me. it helped me a lot. I worked for hours understanding the issue and resolving it but couldn’t get one then i got to this answer and the magic happened.
thank a lot again
God Bless You

Hi, I don’t find where put on my “java file” ? Is-there in “master page.js” ?
Because when I’m putting the following, I’m getting some error ?

Include the following in .java file;

WebSettings settings = webView.getSettings();
settings.setUseWideViewPort(true);

can anyone help me with google signin issue on my wix webview android app?

THANK YOU SOOO MUCH, I spent HOURS with this issue and with just this setUseWideViewPort() inside onCreate() , it fixed everything!!!